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LICENSE AGREEMENT 

NO FEE READ-ONLY VERSION 

BY CLICKING ON THE “Continue” BUTTON, YOU ARE CONSENTING TO BE BOUND BY
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sive license to use its accompanying software product (“Software”) free of charge

if (a) you do not try to sell, modify, or otherwise alter the software in any way; or
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right laws of the United States and international copyright treaties.  Title, owner-



ship rights, and intellectual property rights in and to the content accessed through

the Software is the property of the applicable content owner and may be protected

by applicable copyright or other law. This License gives you no rights to such con-

tent.

DISCLAIMER OF WARRANTY. The Software is provided on an “AS IS” basis, without

warranty of any kind, including without limitation the warranties of merchantability,

fitness for a particular purpose and non-infringement. The entire risk as to the qual-

ity and performance of the Software is borne by you. Should the Software prove

defective, you and not Imspace assume the entire cost of any service and repair. In

addition, the security mechanism implemented by the Software has inherent limita-

tions, and you must determine that the Software sufficiently meets your require-

ments. This disclaimer of warranty constitutes an essential part of the agreement.

SOME STATES DO NOT ALLOW EXCLUSIONS OF AN IMPLIED WARRANTY, SO THIS

DISCLAIMER MAY NOT APPLY TO YOU AND YOU MAY HAVE OTHER LEGAL RIGHTS

THAT VARY FROM STATE TO STATE OR BY JURISDICTION.
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TERMINATION.  This license will terminate automatically if you fail to comply with
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Software.

EXPORT CONTROLS.  None of the Software or underlying information or technology

may be downloaded or otherwise exported or reexported (i) into (or to a national or

resident of) Cuba, Iraq, Libya, Yugoslavia, North Korea, Iran, Syria or any other

country to which the U.S. has embargoed goods; or (ii) to anyone on the U.S.

Treasury Department’s list of Specially Designated Nationals or the U.S.  Commerce

Department’s Table of Deny Orders. By downloading  or using the Software, you are

agreeing to the foregoing and you are representing and warranting that you are not

located in, under the control of, or a national or resident of any such country or on

any such list.





MISCELLANEOUS. This Agreement represents the complete agreement concerning

this license between the parties and supersedes all prior agreements and represen-

tations between them. It may be amended only by a writing executed by both par-

ties. If any provision of this Agreement is held to be unenforceable for any reason,

such provision shall be reformed only to the extent necessary to make it enforce-

able.  This Agreement shall be governed by and construed under California law as

such law applies to agreements between California residents entered into and to be

performed within California, except as governed by Federal law. The application the

United Nations Convention of Contracts for the International Sale of Goods is

expressly excluded.
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Welcome to Kudo

Welcome to Kudo, an exciting way to view digital images. Just as you
consult any catalog for certain products, consult your Kudo catalog for
images, sounds, and movies.

Kudo catalogs are collections of image thumbnails. Think of a thumbnail
as a miniature photo of an image file. It looks like the image file, but it is a
120 X 120 pixel replica that is stored in a Kudo catalog. With these
catalogs of thumbnails, you can easily view, sort, find, and place original
artwork. 

The CDROM that this manual came with more than likely has many
images on it. The publisher’s of the CDROM wanted to give it’s users the
most efficient way of viewing and using the image files contained on the
CDROM. That is where Kudo catalogs come in.

Kudo is a user interface that allows you to view thumbnails, get
information about the images, and place the original images directly into
your documents.

Features

You have hundreds of clip art, logos and other graphic image files on
your CDROM, possibly created using different applications. 
CDROMs with Kudo catalogs have the following features:

• View all images on entire CDROMl.
• Reference the file’s location, size and format.
• Display original full-sized images in a floating window.
• Place the file into another document by just dragging the thumbnail

image into the Aldus PageMaker or QuarkXPress document and
letting go.

• Open your images in the application that created them.
• A single Kudo catalog can contain up to 134,000 thumbnails.

Kudo saves you hours of time normally spent searching for graphics.

Kudo Image Browser User’s Guide
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Quick Start

Kudo™ is easy to install and easy to use. This section will enable you to
install Kudo and become familiar with its most important features in a few
short minutes. Once you become familiar with the basics of Kudo™, you
should then read the remainder of the User’s Guide and then refer to it as
a handy reference when questions arise.

1. Install Kudo by double-clicking on the Installer icon on your
CDROM.

2. The installer will place Kudo and support files onto the drive that
you have selected. The supports files are translators and place
modules that Kudo uses.

3. Double-click on Kudor or a Kudo catalog to launch the program. If
you opened just the application you will be prompted to open a
Kudo catalog.

4. Once a catalog is open, click on a thumbnail to select it. Pull down
the Image menu and select Preview to see the image in a full-sized
window. Click the standard Macintosh close box to close the
preview window.

5. With the thumbnail still selected, pull down the Image menu and
select Reveal Original. The Finder will then locate and reveal the
folder or disk containing the selected image file. Click on the Kudo
window to return to Kudo.

6. Next, click on the List View button. The list view presents
thumbnails along with file information in a column. The Gallery
View button will return you to the gallery view; the grid style layout
that shows more thumbnails but less information.
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Figure 1. The Catalog Window.

7. Click the Find button to open the selection criteria dialog box. This
will allow you to locate thumbnails within the catalog that have
specific characteristics. Click on the first pull down menu and
select “Name” to tell Kudo to search on the name characteristic.
With “contains” selected in the second pull down menu, type in part
of a file name in the box to the right (Figure 2 below). Click the
Find button to search the catalog for all thumbnails that meet the
specified characteristic. Kudo will then display only those
thumbnails. Click the Find button again and select “Everything” in
the first pull down menu to find and display all thumbnails in the
catalog.
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Figure 2. The Find Dialog.

8. Position the mouse cursor over the Riffle™ control (the double-
headed arrow with tick marks) in the lower right-hand corner of the
catalog window. Click and hold the mouse button down over the
Riffle control to zip through the contents of the catalog. Using the
Riffle control is like pressing Play and Fast Forward or Reverse on
a VCR to quickly move forward or backward while watching the
frames flash by. Experiment with this feature and refer to the
section on the Riffle Option later in this guide for further details.

Figure 3. Using The Riffle Control.
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9. Finally, if you are using System 7 and Aldus PageMaker or
QuarkXPress, open a document in that application and position its
window so that it will be visible behind the Kudo catalog window.
Return to Kudo, select a thumbnail and drag it into the document
window. Kudo finds the original image file and places it in that
document in the upper left corner (defined by the document
margins). See Figure 4.

Note: If you use Freehand, Illustrator, Premiere, Fractal
Painter, or Photoshop, dragging a thumbnail onto a
document window opens the original image file in a new
window. This is much faster than opening via a dialog box.

Figure 4. Drag the thumbnail to the document.

These are some of the many features of Kudo. Try the different menu
commands and discover additional features. The following sections of
this User’s Guide provide more detail about all features and about
managing Kudo catalogs.
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Using Kudo
To start using Kudo, install the application and create a catalog.

Installing Kudo

To use Kudo, we recommend using a Macintosh with 4MB RAM that runs
either System 6 or System 7.

Installing Kudo is a no-hassle process. 

• Double-click the Installer icon on the Kudo disk and follow the
instructions. The files will be installed automatically.

Note: If you are installing Kudo onto a Macintosh with an
existing copy of Kudo, simply have the installer replace the
existing Kudo Folder. All the new files will be updated
automatically.

• The Installer will place Kudo into a folder for you.

Note: To take advantage of AppleScript, install the
AppleScript environment from the Kudo diskette labeled
AppleScript Installer.

Opening a Catalog

To open an image catalog, simply double-click it. Kudo will open the
catalog and display the window.

You can open several catalogs at once. Once you have opened a catalog
you can simply choose “Open” in the File menu or double-click another
catalog’s icon. When you choose the next catalog, Kudo will open a
second window. 
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The Catalog Window

The catalog window features make image access even easier. 

Figure 5. The Catalog Window.

Kudo displays several thumbnail images in the window. Below each
thumbnail, Kudo lists the original file name and displays a graphic that
identifies the file type. At a glance, Kudo shows you what the image looks
like and whether the file type matches your need.
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View buttons

The Gallery View, Small Gallery View and List View buttons allow you to
switch between views. Switch between the views by clicking the view
button you prefer.

• The gallery view (Figure 6 below) uses a grid style layout showing
several thumbnails and their file type at once. Click the Info button
to view detail about the selected thumbnail.

Figure 6. The Gallery View.
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• The small gallery view (Figure 7 below) allows more thumbnails to
be viewed within the catalog window by reducing the thumbnails to
1/4 their normal size. The file name is not displayed in this view.
The functionality available within the small gallery view is the same
as that in the gallery view.

Figure 7. The Small Gallery View.
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• The list view (Figure 10 below) uses a vertical layout with fewer
thumbnails in the window, but with more information about each
file. The list view shows the thumbnails in a vertical column and the
file information in a second vertical column. An icon representing
the file type is also displayed in the second column.

Figure 8. The List View.

• You also can change the view using the View menu.
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Find button

Use the Find button to search the catalog for thumbnails with specific
characteristics. Kudo searches the catalog and displays the thumbnails
that were identified in the search. All other thumbnails are hidden from
view. 

For example, if you search the catalog’s notes for a client name, Kudo
only displays the thumbnails with that information. Kudo will not delete or
edit the remaining thumbnails; it just hides them from view. To return to
the full catalog, use Find to search the catalog for “Everything” or choose
"Find All" from the Image menu. 

When you select the Find feature, Kudo displays a dialog. 

• Use the pull down menu to tell Kudo the thumbnail characteristic it
should search. You can search by name, size, kind, creator, date
created, date modified, notes or location.

Figure 9. The Find Dialog.

• Use the next pull down menu to tell Kudo how to search the
catalog. This pop-up window will become available after you make
a selection in the first pop-up window.

Figure 10. The Find Dialog with search criteria.

• Use the “Edit Text” box to tell Kudo what words or information to
search for. 

• You can also choose the Find option using the Image menu.
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Figure 11. The Find Dialog with keywords list.

The keyword editor is available to select keywords when using the Find
command to search the notes attached to thumbnails. To search by
keywords:

• Select “Keywords” from the first pull down menu in the Find dialog.
• Kudo will display the keywords editor pull down menu to the right

of the “Edit Text” box.
• Select the keyword you wish to find and release the mouse button.
• Kudo will insert the keyword into the “Edit Text” box.

Clicking on the “Options” button will expand the Find dialog, showing
more search criteria and several check box options. Use these search
pop-ups to narrow your search when you need to find specific images.

Figure 12. The Find Dialog with search options.

Searches may be expanded to all open catalogs or limited to thumbnails
found in a previous search. For example, you might first search all open
catalogs for all thumbnails which contain the keyword “Plane” in the
notes. Once these are located, you might want to further refine the
search by finding only those thumbnails with a certain file type such as
PICT.
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To expand or limit the search:

• Click on the “Options” button of the Find dialog box.
• Click on the left-hand check box to expand the search to all open

catalogs.
• Click on the right-hand (“Whole Words”) check box to limit the

search to complete keywords. Using the example in Figure 14,
“Plane” would be found, and “Planet” would not be.

Note: The three search criteria are associated with a logical
“And.” In the above example, all three search specifications
would have to be true for the item to be found. Long
searches can be cancelled from the Find dialog by typing
“Command-.” 

Find All Command

The "Find All" command allows you to locate and display all thumbnails in
a catalog. This command can be used to return to the full catalog after
the display has been limited by a search for thumbnails with specific
characteristics.

• Choose "Find All" from the Image menu.
• Kudo will display all thumbnail images in the open catalog.
• You can also use the Find command on the Image menu and

choose "Everything" to return to the full catalog.

Info button

The Info button gives you quick access to a thumbnail’s information. This
option tells you the file name, size, date created, date modified, location
of the original file, any keywords you have attached to the thumbnail, the
name of the application that created the original file, file kind and the
width/height measurements of the original. The width and height
measurements can be viewed in pixels, picas, inches or centimeters. 

• Select a thumbnail.
• Click the Info button.
• Kudo will display the information in a floating window. 
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Figure 13. The Info Window.

• Use the pull down menu in the lower right-hand corner of the Info
window to select the units for the width and height measurements
in pixels, picas, inches or centimeters.

• Use the pull down menu under the Keywords label to automatically
enter  keywords directly into the keyword area. See page 39 for
information on how to use the keyword editor.

• You can also choose Get Info using the “Image” pull down menu.

When the Info window is open, click other thumbnails to display their
information. Close the window using the Close Window button.

Note: Any changes made to the units of measurement or
location of the Info window are retained the next time the
Info window is opened.
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Riffle Buttons

The Riffle buttons are part of Kudo’s exclusive Riffle feature. Turn to page
20 for more information on the Riffle feature.

Close Window Button

The Close Window button is a standard Macintosh feature that closes the
window. With Kudo, this button closes the catalog. 

Zoom Window Button

The Zoom Window button is another standard Macintosh feature. Clicking
it zooms the window to its full-screen size. Click it again to return the
window to its smaller size.

Scroll Bar

Use the Scroll bar to move through the catalog. 

Note: Remember that Kudo will display the catalog based on
the current Find criteria. If you have selected “Everything” in
the Find feature, the entire catalog is available. However, if
you have used Find to select a specific group of files, you
can only scroll through those files. You must set new search
criteria to scroll through your other thumbnails.

Grow Box

The Grow box is the standard Macintosh feature that allows you to re-
size the window. Kudo re-sizes the window proportionally to the
thumbnail size so your window always displays entire thumbnail entries.

The Exclusive Riffle™ Feature

The Riffle option is a special Kudo feature that lets you visually zoom
through your catalog. If you can’t remember the name of the file you need
or you want to review the images you have, use the Riffle option to zip
through the catalog to see what’s there. 

When you use the Riffle option, you fly through the catalog, glancing at
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each thumbnail. You can control the Riffle speed to spend more, or less
time, looking at each image. You can even change the Riffle direction if
you miss an image. Once you recognize an image, simply release the
mouse and the image is right in front of you. 

Using the Riffle Feature

Kudo’s main window displays the thumbnails in a gallery or list format.
When using the Riffle option to zip through the catalog, it displays the
images one at a time in the lower right corner of the main window. 

To zoom through your catalog:

• Click and hold on the Riffle control (Figure 14 below). 
• You will see one thumbnail after another in the lower right corner

just above the Riffle control. 

Figure 14. Using the Riffle control.

• Release the control when you see the thumbnail you want. 
• When you release the Riffle control, Kudo will show the thumbnails

that surround the one you chose. 
• Kudo highlights the thumbnail that you chose. However, your

reactions are slower than Kudo’s Riffle option, so when you
release the Riffle control, you will select a thumbnail that is a few
frames away from the one you wanted. Kudo scrolls the catalog to
the appropriate location and displays the surrounding thumbnails.

Kudo will zoom through the catalog until you release the control or until it
reaches the end of the catalog. With the Riffle feature, you can zoom
forward to the end of the catalog or you can zoom backward to the
beginning. To view the entire catalog, start from the beginning. 
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Controlling the Riffle Speed and Direction

Control the Riffle speed and direction by dragging the mouse to the left or
right while holding it on the Riffle shuttle control. 

By holding down and dragging the mouse, you change speed and
direction of your progress through the catalog.

• Drag the mouse to the right or left to control the speed and
direction. 

• Click the right end of the control to start moving through the
catalog. Drag the mouse to the right to increase the speed. Drag
the mouse to the middle and Kudo will stop riffling. When you drag
further to the left, Kudo will start moving in the opposite direction
and increase speed. 

• You will find the center is the point of zero speed. At this point,
Kudo stops moving and holds on one thumbnail.

• In Figure 14, the thumbnails would be shown in reverse order at a
medium rate.

The Image Menu

Display Original

Kudo maintains a link between the thumbnail image in the catalog and
the original file. While in Kudo use the Preview option to preview the
original image file in a full-sized window. 

18
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Figure 15. The Display Original Screen.

• Select the thumbnail you wish to view
• Choose Display Original from the Image menu or double click on

the thumbnail.
• Kudo will find the actual image file and display it in a full-sized

window. 
• If your system only uses 256 colors, you can choose “Use Better

Colors” under the File menu.

To preview other image files, simply click their thumbnails while the
Preview window is open. QuickTime movies are automatically played
when a thumbnail associated with QuickTime is previewed.

Note: Kudo cannot preview files stored on off-line disks. If the file is on an
off-line disk, Kudo will ask you to insert the correct disk. 

Reveal Original

Similar to the Finder’s Find feature, Reveal Original instructs the Finder to
locate and reveal the image file in its folder or disk window. Once
revealed, you can immediately open and use the file.

• Select the thumbnail.
• Choose Reveal Original from the Image menu.
• Kudo will open the files folder or disk window and highlight the file. 
• Double-click to open the file in the original application.

Edit Original

Kudo maintains a link between the thumbnail image in the catalog and
the original file. While in Kudo you can launch the application that created
your original image file and open that file for editing.

• Select the thumbnail for the file you wish to open.
• In Gallery or List View, Double-click on the file type icon. In Small

View choose the “Edit Original” from the Image menu.
• Kudo will launch the application that created the original file and

open the file.
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Placing Original Images

There are three methods for placing an image into a document:

• Drag and Place
• Using the Place command from the Image menu.
• Copy and Paste. If you copy a thumbnail, then paste it into a

document, the original image will be pasted.

Use Kudo’s special Place feature to place an original image file into
another document. When you select Place, Kudo instructs the target
application (for example, PageMaker) to place the file into the document.

Drag and Place

Kudo has developed a first-of-its-kind technology which allows you to
Drag and Place images into PageMaker and QuarkXPress documents.
Use Drag and Place to save time and save disk space. This single step
operation takes less time than manually placing images into a document.
Kudo inserts a file reference into the target document, eliminating the
need to create an unnecessary copy of your image file.

With the Drag and Place feature, simply drag the thumbnail from your
catalog to an open document. Kudo will find the original image file and
place it in the document. See Figure 4.

• Select the thumbnail.
• Hold down the mouse and drag it to the open document.
• Kudo finds the original image and places in the upper left corner,

defined by the document margins.

Note: Kudo will additionally place the image into a pre-
selected graphic frame when using QuarkXPress. 

Note: System 7 is required for Drag and Place. The Place
Module for the application you are using must be installed in
the Kudo folder and the format of the file being placed must
be supported by that application. Placing an image that
PageMaker or QuarkXPress does not recognize can cause
unexpected results. For example, placing a GIF file into
PageMaker will result in text (not an image as you would
expect) being imported into PageMaker. This may be
overcome in the future.
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• Kudo will find the original image file and place it into the document. 

Note for QuarkXPress Users: "Drag and Place" works with
all QuarkXPress 3.1x versions. This means you can drag
thumbnail images from Kudo and place them directly into
QuarkXPress. If you are using version 3.11, Kudo will install
our XTension, "Kudo XT", into your QuarkXPress folder.
Version 3.2 requires no special XTension and will work
automatically.

Note for Aldus PageMaker Users: "Drag and Place" works
with PageMaker version 4.2 and up. This means you can
drag thumbnail images from Kudo and place them directly
into PageMaker.

Another Way to Use Place

You can also place an image into a supported application using the Place
menu. PageMaker, QuarkXPress and other major applications accept
images using Place from Kudo. 

Note: If you did not receive a Place Module for your
application, contact Imspace Customer Service about
additional Place Modules.

To place an image file:

• Select the thumbnail image.
• Select Place under the Image menu and identify your target

application. Kudo lists every active application that supports the
Place technology.
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Figure 19. The Place menu.

• Kudo instructs the target application to find the original image and
place it in the upper left corner (defined by the document margins).

Note: If available, QuarkXPress will place the image into a
selected graphic frame.

Note: The application you are placing the image file into
must already be open before it will show up under the Place
menu.

Using Copy and Paste

If your target application does not support Kudo’s Place option, export the
image file using Copy and Paste.

• Select the thumbnail image.
• Choose “Copy” under the Edit menu.
• Kudo will find the original image file and copy it to the clipboard.
• Open the target document.
• Choose “Paste” under the Edit menu of the target document.
• Your target application will paste the image onto the document

page.

Note: When you use copy, the entire original image file is
copied to the clipboard. Be sure you have enough RAM to
support this action.
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Sorting

When you open a catalog, Kudo lists the thumbnails according to when
they were added to the catalog. Use the Sort menu to list the thumbnails
by size, date or even location. For example, sort by "Modification Date" to
see which image files have been recently updated or sort by "Kind" to
group images by file type.

You can sort the catalog using the same criteria found in the Find feature.

Figure 20 The Sort Menu.

Sort and Find use the same criteria but they affect the catalog differently.
With Find you use the criteria to determine which thumbnails Kudo should
display and which it should hide from view. With Sort, you re-arrange the
thumbnails that are displayed.

When you close and re-open the catalog, Kudo shows all the thumbnails
in their original order.

To sort your catalog:

• Select sorting criteria.
• Kudo will automatically re-arrange the thumbnails and display them

in their new order.
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Printing Your Catalog

Use the standard Page Setup and Print commands to print part or all of
your catalog. The Print feature always prints the current selection of
thumbnails. For example, to print all thumbnails in a catalog, use the Find
command to find "everything" (the default), and then select print from the
File menu. Kudo prints in "thumbnail increments" on a page (i.e. 9-up on
8 1/2" X 11" paper in Gallery View).

Exporting Catalog Information

The Export command allows you to create a tab-delimited text file
suitable for importing into database applications. This text file includes
pertinent catalog information including file name, size, creation date,
modification date, location and file type. You can import the text file into
various database applications for quick and accurate image database
tracking. To use the Export feature, choose "Export" from the File menu.

Note for QuarkXPress Users: You can use Kudo's Export
feature to automate repetitive image layouts without using
AppleScript. A Quark XTension called "XData" (available
from XChange at 303-229-0656) can read Kudo export files
and use the information provided to help you create large
documents.

Note for Aldus PageMaker Users: You can use Kudo's
Export feature to automate repetitive image layouts. An
Aldus Addition called "Datashaper" available from ElseWare
at 206-547-9623) can read Kudo export files and use the
information provided to help you create large documents.

Other Menu Options

Kudo uses several other menu options that are standard Macintosh
commands. Use these commands as you would use them in other
applications. They include: New, Open, Close, Quit and Show Clipboard.
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The Scripts Menu

The Scripts menu is linked to a “Scripts” folder located in the same folder
as the Kudo application. Any AppleScript placed in this folder will appear
in the Scripts menu alphabetically. The first 9 items will have a command
key associated with them. You can have up to 30 scripts in the folder.

Automating Kudo with AppleScript™

Kudo is a “scriptable” application. This means that it can be controlled by
AppleScript allowing you to automate repetitive procedures. For example,
at the beginning of a work session, you might want to open a set of Kudo
catalogs and then have those catalogs automatically updated with new
images from your hard drive. With AppleScript this can be done quickly
and easily with a few clicks of the mouse.

Kudo is a “recordable,” “scriptable” and “attachable” application. This
means that you can use the AppleScript recorder to create a script and
then run the script from within Kudo. Automating procedures in Kudo
becomes as easy as turning on the AppleScript recorder and performing
the procedure once. More instructions on Applescript can be found in For
More Information on page 34.

AppleScript must be installed before you can use the Kudo scripts or
create your own scripts. AppleScript is installed separately from Kudo
and is on the AppleScript Installer Disk in your Kudo set of diskettes. Just
install it as you installed your original Kudo.
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Figure 23: The Scripts Menu.

Note: The Scripts Menu will remain gray until you install the
AppleScript software from Apple Computer, Inc. It must be
installed on the system from the AppleScript Installer of the
Kudo Installation diskettes. AppleScript requires system
software version 7.0 or later.

Creating and Editing a Script

Kudo uses the Apple Script Editor to create new scripts by recording
actions and commands while you are in Kudo. You can activate these
scripts later to automate your work. Creating a new script is easy.

• Open a Kudo catalog. This will be the catalog you will be working
with.

• Select “Open Script Editor” in the Scripts menu.
• Kudo will launch the Apple Script Editor application and display a

new “Untitled” script window.

Note: The first time you run this command, AppleScript will
ask you to find the Script Editor. After you run the installer, it
will be located in a folder called “Apple Scripting System.”

Figure 24. The Script Editor New Script Window.

• Click the “Record” button to start the scripting process.
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• Click on the Kudo catalog to bring Kudo to the foreground.
• Select “Add/Update” from the File menu and select a file, folder or

volume that you want Kudo to automatically scan.

Figure 25. The Script Editor Window.

• The Script Editor records the “Add/Update” command in the
AppleScript language. You can experiment with different
commands to see how Kudo can be scripted.

• Click on the Script editor and bring it to the foreground. Click on
the “Stop” button to finish the recording session.

• Select the Script Editor window and choose “Save As” from the
File menu. You are presented with a Save dialog to name the
script that you are creating.

Figure 26. The Script Editor Save-As Dialog.

• Save the script into the “Scripts” folder that is in the “Kudo®
Catalog Reader” folder. This will make your script appear in the
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Kudo Scripts menu. Save this example as “Update Kudo Catalog.”
• Close the Script Editor by choosing the Close Window Button.

Running a Script

Running the scripts that you create with the Script Editor or running the
included Kudo Scripts is a simple as pulling down a menu. To run the
sample script that you just created:

• Choose the “Update Kudo Catalog” from the Scripts menu.

Figure 27. The Scripts Menu.

• Kudo will automatically execute the “Add/Update” command on the
file, folder or volume you selected.

Kudo Scripts

Kudo includes a number of scripts that automate common tasks. These
scripts can also be modified to increase their capability. Feel free to
experiment with them. Open them with the script editor to see how they
work, and make your own custom solutions!

For More Information on AppleScript

• See the AppleScript Appendix on page 48. 
• The AppleScript Installer disk that is included with Kudo contains

sample scripts and a HyperCard reference stack.
• AppleScript Extras can be found in the Kudo folder installed on

your hard drive. It contains advanced scripts which can be installed

Kudo Catalogs User’s Guide
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into your Scripts Folder. It contains associated read-me files which
can be printed for more instructions.

• Apple Computers offers you a host of companion products
available through APDA (Apple Programmer & Developer
Association.) APDA can be reached in the United States at (800)
282-2732; in Canada at (800) 637-0029; or internationally at (716)
871-6555.

Apple events/AppleScript Programming Tutorial
R0224LL/A $150 (U.S.)

AppleScript Developer’s Toolkit
RO175LL/A $199 (U.S.)

Kudo Catalogs User’s Guide
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Making Catalogs Available to Others

Sharing Catalogs on a Network

Kudo catalogs can be accessed concurrently by multiple users if the
catalog is Read-Only. Users may view, search and perform Drag and
Place operations but changes cannot be made to the content of the
catalog. Locking of the catalog file as Read-Only is done from within the
operating system.
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Troubleshooting

The Place command on the Image menu never has anything under it
even though it appears to be a submenu selection.

Application names only appear as submenu selections under the Place
command on the Image menu if that application is currently open and a
Place Module for that application is located in the Kudo folder. If nothing
appears under this command, return to the Finder, insure that the Place
Module is installed in the Kudo application folder and open the
application. If your application still is not listed in the Place menu, contact
Imspace Systems Customer Service for additional Place Modules.

Nothing happens when you drag a thumbnail into a PageMaker or
QuarkXPress document.

Applications such as PageMaker and QuarkXPress only support the
importing of specific file formats. If a file format is not supported by the
application you are using, nothing will happen when you drag the Kudo
thumbnail into the application document. Consult the documentation
provided with the application to determine which file formats are
supported or copy and paste the thumbnail from Kudo.

“Script” pull down menu is gray.

The AppleScript extension must be loaded into your System Folder. Use
Kudo disk 3 and install AppleScript with the included installer. Note:
AppleScript only runs on System 7.
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AppleScript Appendix

Kudo Suite of Commands

Delete: Mark a thumbnail for deletion.
A. Delete (Selected Thumbnail) of Catalog 1
B. Delete Thumbnail 23 

Kudo marks the thumbnail for deletion, and actually deletes it when you
close the catalog.

Do Script: Run a script from Kudo's Scripts menu.
Do Script “Update FileMakerPro”

This command can be used by applications that do not have robust
AppleScript support. Have the application send Kudo the Do Script Apple
Event and Kudo will run the Script. Kudo will only run scripts that are
located in the Kudo “Scripts” folder.

Preview: Display preview window for a thumbnail.
A. Preview Thumbnail 4 of Catalog 1
B. Preview (Selected Thumbnail) of Catalog 1

Use this command to make Kudo display the preview of a Thumbnail.

Show: Find specified thumbnails.
A. Show every Thumbnail of Document 1
B. Show (every Thumbnail whose Kind is “TIFF”) 
C. Show (every Thumbnail whose Comments contain “Plane”)

This is the same as the Kudo “Find” dialog. Example A demonstrates the
equivalent of “Find All,” and examples B & C show how to find thumbnails
with specific characteristics.

Sort: Sort thumbnails in a window.
A. Sort Catalog 1 by NameSort
B. Sort Catalog 1 by KindSort

This command tells Kudo to sort the catalog.

Undelete: Undelete a previously deleted thumbnail.
Undelete Thumbnail 1 of Catalog 1

Update: Add/Update image files to a Kudo catalog.
Update Catalog 1 with alias “Hard Drive:Clip Art”

This command will tells Kudo to update its catalog with the specified file,



Kudo Catalogs User’s Guide

folder or volume.
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